072 - 201 61 16 31722016116

Professionele bouwers van jouw nieuwe game pc op maat

Nu met gratis Windows 11

Google stopt Manifest V2-extensies voor Chrome, verplichte V3 vanaf 2023

datum: 24-09-2021Categorie: SoftwareBron: Tweakers

Vanaf juni 2023 ondersteunt Google Chrome geen extensies meer op basis van de vereisten van Manifest V2. Per 17 januari 2022 worden nieuwe extensies op basis van Manifest V2 niet meer opgenomen in de Chrome Web Store.

Ontwikkelaars hebben tot begin 2023 de tijd om bestaande extensies compatibel te maken met Manifest V3, aldus Google in een blogpost . Vanaf dat moment kunnen bestaande V2-extensies niet meer geüpdatet worden om aan de nieuwe eisen te voldoen. Wanneer versie drie van de extensievereisten uiteindelijk verplicht wordt, zullen alle momenteel niet-geüpdatete extensies op basis van Manifest V2 niet meer werken.

Het huidige formaat voor Chrome-extensies is begin dit jaar uitgebracht en legt een sterke nadruk op privacy, prestatieverbetering en beveiliging. Het is niet langer mogelijk voor V3-extensies om remote code te gebruiken , wat het voor Google gemakkelijker moet maken om de beveiliging van een extensie te testen. Daarnaast maakt het nieuwe formaat het voor servicemedewerkers mogelijk om bepaalde taken op de achtergrond uit te voeren. Dit elimineert de noodzaak voor extra webpagina's voor secundaire functies, wat het RAM-verbruik van Chrome zou moeten verminderen.

Ten slotte werd een controversiële nieuwe declarativeNetRequest -api geïntroduceerd om de huidige webRequest -api te vervangen. Dit maakte adblockers moeilijker , ten gunste van de privacy van de gebruiker. De betreffende api is inmiddels aangepast om zowel de wensen van ontwikkelaars als de privacy van gebruikers te waarborgen.

Nieuws overzicht
KvK nummer:  68747640
BTW nummer:  NL857574176B01